ITS

Information Technology Services
Information Technology Services

Meltdown and Spectre security vulnerabilities affect your devices  

Over the last few weeks, Security researches discovered two significant hardware vulnerabilities called Meltdown and Spectre. The vulnerabilities affect Intel, AMD, ARM and other chips used in all modern devices. 

How does this affect me? 

Most devices - from smartphones to hardware in data centres - may be vulnerable to some extent.  Both Meltdown and Spectre consist of attacks against modern CPU microprocessors that can result in unauthorized code reading data it should not have access to.  Vendors are working on (or have already released) patches to mitigate the issue.   

How can I protect myself? 

Updates for systems managed by ITS will begin next Tuesday. Additional updates will follow. Please install updates as you are alerted. 

Be vigilant in checking for updates and patches over the coming weeks, and update as soon as they become available. Also ensure your anti-virus software remains up-to-date. Please spread the word with your colleagues, friends, and family. 

For more information about Meltdown and Spectre, you can visit: secwonks.org/real-time-risk-assessment-of-spectre-and-meltdown/

Tags: